PDA

View Full Version : shadercache causing very long delay after reformatting my pc



iconofsin
26.11.2017, 19:18
I recently reformatted my pc

Before i reformatted the the games title screen would appear the instant the shader cache compile finished.
Now there is a long black screen between the shader cache finishing compiling and the game title screen appearing.

I am using the same CEMU and game codebase (i copied them to a USB drive before the reformat)
I am using the same version of windows 10
All of my drivers have been updated and were up to date before the reformat (so very little room for change there)

The only difference i can think of is my Nvidia drivers are now 1 version newer.

I have experimented by downloading a fresh copy of cemu and moving components from my old installation one by one (shadercache, mlco1, graphicspacks ect)
and I have discovered if i delete my shader cache entirely (precompiled and transferable) the problem goes away.
so it seams to be my shader cache causing the problem

I have tried completely recompiling my shaders by deleting only the precompiled folder and rebuilding from the base transferable one but this make no difference.

I have not yet tried other shadercaches

IS this a known problem and is there any fix?

Xalphenos
29.11.2017, 03:43
Try deleting the nvidia glcache and the ore compiled .bin and then run the game. This will do a slow first time compile. After that try loading the game again and see if the compile speed is back to normal.