Close

Page 22 of 23 FirstFirst ... 1220212223 LastLast
Results 211 to 220 of 229
  1. #211
    New user
    Join Date
    21.06.2018
    Posts
    2
    Quote Originally Posted by epigramx View Post
    That's odd, it should work with the generic csr 4.0 without much. Is it an updated windows (what version?) and not from a virtual machine? (if you don't know what that means nevermind).

    Occasionally the windows system that lists them bugs and turning it off/rebooting/or removing the pairing and re-establishing it works. In general I get little to no issues with it lately.
    Hi, I have a win7 machine (not virtual) and the patches are up to date (I manually tried to install the patch from the initial post but I got the message it was already installed). I'm already using a xbox360 controller, so I installed the EmulatedGamepadsDriver using the installer provided but I haven't installed the xbox360 driver as I assume the drivers are already there.

    I'll delete the bluetooth controllers from windows tonight and start the process again. (I'll copy the log and the screenshots here if it still doesn't work). If you have any idea before I do that I'd really appreciate your feedback.

    Thanks for your help!

  2. #212
    Super-Moderator epigramx's Avatar
    Join Date
    13.09.2017
    Posts
    385
    Quote Originally Posted by glados View Post
    Hi, I have a win7 machine (not virtual) and the patches are up to date (I manually tried to install the patch from the initial post but I got the message it was already installed). I'm already using a xbox360 controller, so I installed the EmulatedGamepadsDriver using the installer provided but I haven't installed the xbox360 driver as I assume the drivers are already there.

    I'll delete the bluetooth controllers from windows tonight and start the process again. (I'll copy the log and the screenshots here if it still doesn't work). If you have any idea before I do that I'd really appreciate your feedback.

    Thanks for your help!
    As I describe on the first post, if it's Windows 7 (anything below 8) and if it's the 0x0330 device reported at the start (instead of 0x0306) then the Toshiba Stack might be needed (or there may be pairing but no proper communication).
    Author of WiimoteHook; co-author of Static FPS mods, author of guides to game assembly patching , compiling mesa and high-res screenshots

  3. #213

    Input resets to keyboard after first input

    Hi, sorry if you have answered this somewhere, I tried my best to find something on reddit and here

    I have gotten a genuine wiimote and wiimote+ to pair and map the buttons inside of Cemu (I have a BT 2.1 toshiba dongle and a 4.0 windows dongle). However, after the first input on MK8 (press A to play) the controls reset back to keyboard controls everytime I try to use the Wiimotes.

    Using the toshiba dongle, cemu (1.12.2) does not natively detect them, but they show up for xinput. Using the 4.0 dongle, it is natively detected and also works under the xinput menu.

    This issue happens regardless of how I pair them.

    (Win10 btw)

    Please, any info would be greatly appreciated, and thanks for the hard work

  4. #214
    Super-Moderator epigramx's Avatar
    Join Date
    13.09.2017
    Posts
    385
    I'm not sure if your issue is WiimoteHook related or strictly Cemu. As far as I remember Cemu had a bug for MK8 - and it might still be there (I haven't checked) - that if the emulated Wiimote was selected in Cemu, it would stop sending input after the first "A" is pressed in-game.

    This might not apply to you but I sense some confusion from others in general so I should clarify for everyone:

    WiimoteHook:
    • Standalone software for the Wii Remote that optionally does:
      • a) XInput (or DS4) emulation (XInput/DS4) works on any supported game or software, including Cemu's input settings)
      • b) Runs a server that supports Cemuhook's motion/button input for the emulated GamePad of Cemu.
    • What that means for Cemu:
      • If the emulated GamePad is selected it can provide it with motion data; if any other emulated controller is selected (Pro, Wiimote, Classic) it can provide it with button input
      • If the emulated Wiimote is selected it does not provide it with motion data because Cemuhook does not support that.

    PS. It goes without saying the native wiimote support of Cemu overlaps in functionality, however, it does not provide motion to the emulated GamePad.
    Author of WiimoteHook; co-author of Static FPS mods, author of guides to game assembly patching , compiling mesa and high-res screenshots

  5. #215
    Quote Originally Posted by epigramx View Post
    [*]If the emulated GamePad is selected it can provide it with motion data; if any other emulated controller is selected (Pro, Wiimote, Classic) it can provide it with button input

    Thankyou, this did indeed fix it. Using it as a gamepad (and remapping buttons) worked wonderfully with tilt steering. Thanks for the fast reply, seriously.

  6. #216
    New user
    Join Date
    25.07.2018
    Posts
    5

    Question

    I'm using a genuine Wiimote with motion plus (TR model) on Windows 10 Pro 64 bit. I followed your instruction and have been able to pair the device using WiimoteHook but when I look under "Cemu Options\Gamepad Motion Source" there's no device listed as connected, by slot or by MAC. In the input settings in Cemu I can assign keys on the Wiimote and even use it as a mouse using WiimoteHook so it's definitely paired. Any ideas? I figure I'd ask here before buying a Dolphin bar.

    Thank you

    *EDIT* Using Cemu v1.12.2d

  7. #217
    Do you have the latest cemuhook installed in your cemu folder?

  8. #218
    New user
    Join Date
    25.07.2018
    Posts
    5
    Quote Originally Posted by corrifa View Post
    Do you have the latest cemuhook installed in your cemu folder?
    Ahh I knew I was forgetting something. Yes I'm also using the latest version of CemuHook.

  9. #219
    Super-Moderator epigramx's Avatar
    Join Date
    13.09.2017
    Posts
    385
    Follow the steps to use PadTest as a test; I doubt DolphinBar would fix anything since the software already works at the HID level. Problems could be Cemu having a different port or ip on a cemuhook.ini, WiimoteHook not being able to run the motion server because of a similar server running in the background (that would be reported on the console).
    Author of WiimoteHook; co-author of Static FPS mods, author of guides to game assembly patching , compiling mesa and high-res screenshots

  10. #220
    New user
    Join Date
    25.07.2018
    Posts
    5
    Quote Originally Posted by epigramx View Post
    Follow the steps to use PadTest as a test; I doubt DolphinBar would fix anything since the software already works at the HID level. Problems could be Cemu having a different port or ip on a cemuhook.ini, WiimoteHook not being able to run the motion server because of a similar server running in the background (that would be reported on the console).
    There's so many steps to pairing a device on Windows that it's easy to forget or leave things out. I apologize.

    I have a PS3 controller paired using a BT-400 dongle and the SCP driver so when I initially fired up WiimoteHook, it gave me an error that it was using the same port as SCP Driver. I had to manually change the port in the WiimoteHook config file. Could using a different port be the culprit? I thought it would give an error if it didn't like that particular port. If so which port would you suggest I use if I one would need to change it do to the SCP Driver setup?

    Thanks for the quick replies

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •