Close

Page 17 of 23 FirstFirst ... 71516171819 ... LastLast
Results 161 to 170 of 226
  1. #161
    Super-Moderator epigramx's Avatar
    Join Date
    13.09.2017
    Posts
    366
    Quote Originally Posted by manitislate View Post
    Here are a couple of screenshots.
    If you downloaded it from here (and not an illegitimate source) it's a false positive. Get the file from the first post and update windows to latest and check again.

    Since nobody else sees that on the exact same defender version, you were likely infected by other means if it's not a false positive. Clean with other tools.

    Quote Originally Posted by mrspocko View Post
    Can you upload an update with the configuration of the new cemu 1.11.15 with wiimote support?
    Sorry for my bad english
    I'm not sure what you need exactly. If you mean a profile, I never uploaded these here.

    If you mean motion support to emulated wiimotes, ask rajkosto/cemuhook to add it.


    If you get WiimoteHook from illegitimate sources and not here you're on your own.
    Last edited by epigramx; 28.02.2018 at 04:53.
    Author of WiimoteHook; co-author of Static FPS mods, author of guides to game assembly patching , compiling mesa and high-res screenshots

  2. #162
    Quote Originally Posted by epigramx View Post

    I'm not sure what you need exactly. If you mean a profile, I never uploaded these here.

    If you mean motion support to emulated wiimotes, ask rajkosto/cemuhook to add it.

    If you get WiimoteHook from illegitimate sources and not here you're on your own.

    First, thanks for answering
    Now in cemu you can configure a Wiimote, so I saw in Wiimotehook the config file is emulating the gamepad.
    What I wanted to ask you is if you can upload or send me a config file configured for Wiimote
    That is, for this
    Click image for larger version. 

Name:	Sin título.jpg 
Views:	79 
Size:	150,6 KB 
ID:	294

  3. #163
    Super-Moderator epigramx's Avatar
    Join Date
    13.09.2017
    Posts
    366
    Quote Originally Posted by mrspocko View Post
    First, thanks for answering
    Now in cemu you can configure a Wiimote, so I saw in Wiimotehook the config file is emulating the gamepad.
    What I wanted to ask you is if you can upload or send me a config file configured for Wiimote
    That is, for this
    Click image for larger version. 

Name:	Sin título.jpg 
Views:	79 
Size:	150,6 KB 
ID:	294
    As far as I know the buttons should work with XInput if you select an XInput controller based on WiimoteHook. But, as I said, as far as I know motion will not work because Cemuhook does not support that.

    You can ask Rajkosto(of Cemuhook) if he's going to do it but last time I heard he didn't want to.
    Author of WiimoteHook; co-author of Static FPS mods, author of guides to game assembly patching , compiling mesa and high-res screenshots

  4. #164
    Super-Moderator epigramx's Avatar
    Join Date
    13.09.2017
    Posts
    366
    Quote Originally Posted by mrspocko View Post
    First, thanks for answering
    Now in cemu you can configure a Wiimote, so I saw in Wiimotehook the config file is emulating the gamepad.
    What I wanted to ask you is if you can upload or send me a config file configured for Wiimote
    That is, for this
    I tested the latest version and it seems the emulated portion of the wiimote is incomplete (also confirmed by Exzap), it's not only Cemu's native method that is incomplete. So it doesn't work fully even if we only wanted to use XInput buttons from Wiimotehook without motion.

    tl;dr: the emulated wiimote in the input settings of Cemu 1.11.5 is for most games mainly for booting and not playing yet.

    PS. A game that might have better support for it is Smash Bros.
    Last edited by epigramx; 09.03.2018 at 11:47.
    Author of WiimoteHook; co-author of Static FPS mods, author of guides to game assembly patching , compiling mesa and high-res screenshots

  5. #165
    Hello I have a problem with Wiimote Hook
    The Calibration point is not staying at one place, when i turn the wiimote 180 Degress it moves towards that direction and moves slowly back a bit but not completely to the origin point
    And I also think that the Calibration is not working ok picture http://prntscr.com/iphcyu
    I am aiming straight at my monitor buttons are up

    Note: I have the Scp Driver and WiinUSoft installed (Not the Driver from your Package) but tested it with and without running it same results

    Video:

    I am only tilting the WiiMote Left and Right and Left and Right but the clibration point is always getting off set

    https://drive.google.com/file/d/198f...ew?usp=sharing
    Last edited by Alinach; 10.03.2018 at 23:55. Reason: Adding a Link

  6. #166
    Super-Moderator epigramx's Avatar
    Join Date
    13.09.2017
    Posts
    366
    Quote Originally Posted by Alinach View Post
    Hello I have a problem with Wiimote Hook
    The Calibration point is not staying at one place, when i turn the wiimote 180 Degress it moves towards that direction and moves slowly back a bit but not completely to the origin point
    And I also think that the Calibration is not working ok picture http://prntscr.com/iphcyu
    I am aiming straight at my monitor buttons are up

    Note: I have the Scp Driver and WiinUSoft installed (Not the Driver from your Package) but tested it with and without running it same results

    Video:

    I am only tilting the WiiMote Left and Right and Left and Right but the clibration point is always getting off set

    https://drive.google.com/file/d/198f...ew?usp=sharing
    Is this a genuine Wiimote from Nintendo? I wouldn't trust any knockoff coming from Ebay and the like.

    It's a 0x0306 and if it has MotionPlus bundled in it the only genuine Nintendo ones are usually the early special Zelda: Skyward Sword etc. editions.

    I'm not exactly sure what the issue is though without seeing the physical device's movement but it doesn't remind of anything (even the inverted axes issue which is altered with the "DoNotInvertMotionPlusAxesOnLegacyRemotes" .config key).

    I thought that if the issue is related to the multipliers for the gyroscope axes I could provide a customization of them in the .config (because the static calibration data aren't fully reverse engineered and I've seen an issue with them in a knock-off discrete MotionPlus extension (they were slightly off)), but it doesn't seem to be related to that either necessarily.
    Author of WiimoteHook; co-author of Static FPS mods, author of guides to game assembly patching , compiling mesa and high-res screenshots

  7. #167
    Thanks for your reply

    My Wiimotes are genuine Black Nintendo Wiimotes with Wii MotionPlus inside they came with my brand new sealed Nintendo Wii Crhistmas 2011 bundled with Mario Kart inside so I doubt that they'd be illegitemate
    Just checked; SkyWard Sword came out in September 2011 maybe they used these in the European Mario Kart bundles ?

    I have exactly these ones https://i5.walmartimages.com/asr/0f8...0&odnBg=FFFFFF

    And I also made a Video with Handcam and ScreeenRecording:

    https://drive.google.com/file/d/1QZj...ew?usp=sharing

    And also when I connect my wiimote with an Extension e.g. Classic Controller Pro or nunchuck it show up as DualShock 3
    Last edited by Alinach; 11.03.2018 at 12:28. Reason: Link

  8. #168
    Super-Moderator epigramx's Avatar
    Join Date
    13.09.2017
    Posts
    366
    Quote Originally Posted by Alinach View Post
    Thanks for your reply

    My Wiimotes are genuine Black Nintendo Wiimotes with Wii MotionPlus inside they came with my brand new sealed Nintendo Wii Crhistmas 2011 bundled with Mario Kart inside so I doubt that they'd be illegitemate
    Just checked; SkyWard Sword came out in September 2011 maybe they used these in the European Mario Kart bundles ?

    I have exactly these ones https://i5.walmartimages.com/asr/0f8...0&odnBg=FFFFFF

    And I also made a Video with Handcam and ScreeenRecording:

    https://drive.google.com/file/d/1QZj...ew?usp=sharing

    And also when I connect my wiimote with an Extension e.g. Classic Controller Pro or nunchuck it show up as DualShock 3
    Ah, wait a second, a closer inspection appears to indicate your accelerometer ends up giving values way outside the range of (-1,1) (which was also apparent on the first video). That's pretty interesting and peculiar because it has never come up before and there is full usage of hardware calibration data from accelerometers anyway (unrelated to MotionPlus calibration I had mentioned, though I can't be certain the M+ calibration is perfect there either).

    Let's see what MIGHT be going on here...

    OK, try the latest version uploaded now. But, even if it's fixed with it, send me the WiimoteHook.log.txt generated by it please.

    It includes a way to avoid wrong calibration data and it also logs what it gets about that.

    The first post is updated with a new version.


    PS. Regarding the extensions issue I'm not aware of what is going on but it might have better behavior if the application is restarted after the extension connection or also if the wiimote itself is restarted; it might be also related to recent updates related to linux support. On the first issue the log file might shed light even if the latest update hasn't fixed it.
    Last edited by epigramx; 11.03.2018 at 15:57.
    Author of WiimoteHook; co-author of Static FPS mods, author of guides to game assembly patching , compiling mesa and high-res screenshots

  9. #169
    It seems to work a little bit better somehow, because before, it would glitch out at times and then the Motion Controls wouldn't be useful at all and then I'd have to relaunch Wiimote Hook.
    But the non-fixed calibration point issue and the slowly crawling back to position bug is still present

    The log.txt
    https://drive.google.com/file/d/16q5...ew?usp=sharing
    Last edited by Alinach; 11.03.2018 at 22:14.

  10. #170
    Super-Moderator epigramx's Avatar
    Join Date
    13.09.2017
    Posts
    366
    Quote Originally Posted by Alinach View Post
    It seems to work a little bit better somehow, because before, it would glitch out at times and then the Motion Controls wouldn't be useful at all and then I'd have to relaunch Wiimote Hook.
    But the non-fixed calibration point issue and the slowly crawling back to position bug is still present

    The log.txt
    https://drive.google.com/file/d/16q5...ew?usp=sharing
    Thanks.

    Right. That's some weird calibration data that that wiimote returns for the accelerometer (first line). But if I feed them to my wiimotes I get nowhere near your results so it's not an issue with them being bogus per se and they are not too far from the norm so it's what the hardware finally returns as a value that is throwing it off and not the calibration as I initially assumed.

    I'm short of time with work projects right now so I can't spend too much time re-writing and number-crunching-guessing for it so if you can run this test version for a few seconds while the wiimote is at rest and buttons up (as you start you last video) and send me that spammy log, just to see what kind of raw values it sends that might help to do it faster.

    PS. You could turn it upside-down for the last couple of seconds just to see if it does anything differently interesting but it's not too important.
    Author of WiimoteHook; co-author of Static FPS mods, author of guides to game assembly patching , compiling mesa and high-res screenshots

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •