Close

Results 1 to 6 of 6
  1. #1
    New user
    Join Date
    27.11.2017
    Posts
    2

    Fast stick issue with pro controller config in twilight princess

    Hello there,

    First of all, thanks to the development team for keep working and improving this amazing emulator. I was running the last months with an "issue" when it comes to play Twillight Princess. Somehow when I use the analog stick to tilt in any diagonal direction, Link starts to run as hell, this ended up to fallings from platforms to pits accidentally so I had to start to be more precise with the tilting in order to not be falling myself everytime. When I got the bow I realized that when I had to aim, the pointer always return to its original point when I move in diagonal as well. I took a look to input settings and get some play with the deadzone... so... it worked! But not in a pretty good way, I meant, Link still ran too fast but the pointer seemed to not return to its original point in some diagonal directions... however when I got the hookshot for the first time I just realized that the game was utterly frustrating trying to aiming at those spot in lakebed dungeon, everytime moving to its original point when you bring out the hookshot.

    However... good news! After all it was as easy as change the profile from Pro Controler to Gamepad... so no more Link running fast & issues with aiming weapons. After deciding to write down this thread... trust me... I search all around and I didn't find any subject related to this issue so maybe could be a special case, a mix of some specs or who the hell knows...

    My specs as stated below are:

    i7-4790k
    GTX 1080 (388.31)
    Cemu 1.11.0c (I updated to the last version hoping this'd be fixed but it didn't)

    I played either with keyboard or Xbox One Controller. At first I thought it was problem with the gamepad but I was pretty surprise when the same happened with the keyboard. Just to know if this a common issue or someone experience this so far.

    Regards.

  2. #2

  3. #3
    New user
    Join Date
    27.11.2017
    Posts
    2
    Quote Originally Posted by angmarec View Post
    Just FYI I managed to resolve this finally! It was the DirectInput all the time which was causing this annoying issue, I just had to switch to Xinput. I think this the recommendable input config whenever you have a controller compatible with Xinput. I have a really specific setup which involves the use of steam link along Big box which fires up Cemu, just for better organization purposes, so at launch I just had to config "allow desktop config for controller" from Big Picture for Big Box, somehow I tried Xinput this time instead of DirectInput and finally the Xbox One Controller was detected and everything working like a charm right now.

    Might be your cause, hopefully you can solve the issue you're having!
    Last edited by Enot; 30.11.2017 at 11:00.

  4. #4
    Super-Moderator epigramx's Avatar
    Join Date
    13.09.2017
    Posts
    338
    Another benefit of XInput is that most DirectInput implementations do not support Rumble.

  5. #5
    Thank you. It realy helps!

  6. #6
    Thank you, resolve my problem with super smash bros U!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •