It's been about 2 hours now that I've been trying to setup the mayflash adapter to be able to use the gamecube controller on cemu for sm4sh. The game is working fine, I can play it with my wii u pro controller, I have uninstalled all drivers for the mayflash gamecube adapter, I tried using zadig to make it work (but it only works for dolphin), I tried using Wii U GCN USB driver from this website http://m4sv.com/page/wii-u-gcn-usb-driver but it does not detect my adapter, I have tried running cemu alone without any game and while I managed to go to Input Settings -> Emulate Controller as a Wii U Pro Controller -> Selecting DirectInput -> Choosing the first mayflash adapter option and settings each button to save the controller config. But once I start sm4sh and I select the Controller Profile with the buttons set, it still freezes and crashes. I tried choosing to emulate the gamepad or the wii u classic controller but still no results. I also went into mayflash's website to download the firmware updater thing they had and updated it but there's still no improvement.

I am usually greeted with a blank notification thing without any text when starting the game and sometimes before I even get to do anything it crashes. I am out of ideas and don't know what to do anymore.

Thank you.