Results 1 to 10 of 10
  1. #1

    A workaround for BotW No-AA Fuzzy Combs on Objects

    Edit: It's now inside resolution packs

    Ps: If you want to use Contrasty, open this txt, the 4th line, "const bool Use_Contrasty = false",change 'false' to 'true' to turn Contrasty on. So that you get Contrasty enabled.
    Screenshot compare: Fuzzy combs and fixed

    Found the reason why some ppl are getting combs with AA Removal while others don't:
    The latest AA Removal is supposed to be used together with Contrasty, the shader Contrasty uses contains part of AA which getdls removed as well.
    So if not using Contrasty, u get a broken AA Removal.

    I know nothing about shader edit so i just went ahead and added an if condition to toggle the output xD
    Tested a while, no combs seen so far.

    ( ☆ Thanks to TheComplainingGamer for bringing this out. )
    Last edited by NAVras; 26.09.2017 at 18:04.

  2. #2
    Super-Moderator Serfrost's Avatar
    Join Date
    Alright, I can definitely see the difference this time. lol

  3. #3
    coconut tree/palm tree is other exemple, i guess.

  4. #4
    New user
    Join Date
    Glad to see I was not the only on noticing this.
    It is subtle in 4k, it's noticeable in images with high contrast, but it's always there.
    Click image for larger version. 

Name:	aa1crop.png 
Views:	178 
Size:	49,6 KB 
ID:	51

  5. #5
    @Kiri yea not many notice this, but I got one report on reddit saying amd doesn't have this problem... btw your inventory fix works like a charm xD

    update: another dirty fix/workaround to make this kinda compatible with contrasty, again not reliable cuz this's just based on observation.
    Tested in 1.9.1, cemu always chooses the first one if there's two shaders with the same name.
    So renaming AARemoval folder to sth like "NoAA" will make cemu use the one in "Contrasty" if it's enabled.

  6. #6
    New user
    Join Date
    That workaround is not pretty

  7. #7
    @Kiri well, got another less bad one here xD
    Update: Adding an option inside the shader to toggle Contrasty on or off
    const bool Use_Contrasty = true
    change 'true' to 'false' can turn Contrasty off.

    Post is updated.
    Last edited by NAVras; 25.09.2017 at 14:13.

  8. #8
    Pushed to github graphic pack repo by @JoelAlone . Now in resolution pack.

  9. #9
    New user
    Join Date
    I am working on a fxaa shader. I implemented it for the 3D model in the inventory screen.
    But for this to work on the rest of the game, it can only work by modifying the Contrasty shader.
    Is this a good idea? Adding an option inside the same shader (f14bb57cd5c9cb77) to toggle fxaa on or off?
    We can just rename the shader to something like "Generic postprocessing". What do you think?

  10. #10
    yea we can, but need to ask slash and others' advice
    btw nice shader edit as usual ~ xD

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts