Close

Results 1 to 3 of 3
  1. #1

    Horrible Screen Tearing on GSync Monitor Playing BotW Cemu 1.11.3

    Specs:
    Windows 10
    16GB Ram
    Intel i5-6600K 3.50GHz
    GeForce GTX 970 (Driver 388.71)
    Dell S2716DGR 27" 144hz TN G-Sync Monitor

    Running Cemu 1.11.3 with latest Cemuhook, the settings from this video (https://www.youtube.com/watch?v=SR7BA3WpWd4), and the following Graphic packs: FPS++, 2560x1440, Square Kakariko Torches, NVidia Explosion Smoke, and High Resolution Shadows

    Playing Breath of the Wild in Cemu 1.11.2 and I have silky smooth framerate at an average 45fps. When I upgrade to 1.11.3 I started getting horrible screen tearing. It's especially noticeable when moving the camera up and down. This is despite obtaining consistent 60fps on a 144hz Gsync monitor. I was running with Dual-core recompiler and tried reducing it to Single-core. While that reduce the tearing, it did not eliminate it. I've tried adjusting a few other settings such as toggling, v-sync, RDSTC, Full Sync at GX2DrawDone, GX2SetGPUFence skip, but no changes. The only thing I've found that fixes the tearing in 1.11.3 is turning on the 30fps Graphic Pack. So the determining factor seems to be when I hit 60fps (with Single-core recompiler I'd get the tearing again in high FPS areas like the shrines which supports my theory).

    All other games and Cemu 1.11.2 work perfectly with Gsync and have no screen tearing, even with unstable framerates.

    Any ideas on what's happening?

  2. #2
    I slight update. I have since made a couple adjustments. One is I turned on Full Sync on GX2DrawDone() in order to fix the unrelated AI bug in BotW. This means I now never hit 60fps except in Shrines. Second, is I set Precompiled Shader Cache to Disabled/ignored to eliminate the framerate judder. Third, is I added the BSoD Framerate Unlocker graphic pack and configured it to set vsyncFrequency to 55fps.

    The issue still remains, anytime framerates hit 60fps and above there is screen tearing.

  3. #3
    New user
    Join Date
    11.01.2018
    Posts
    7
    My ingame framerate fluctuates between "40 - 80" and there is no screen tearing occuring.
    Nvidia settings and cemu.exe:
    Click image for larger version. 

Name:	1.jpg 
Views:	26 
Size:	73,2 KB 
ID:	232
    Click image for larger version. 

Name:	2.jpg 
Views:	19 
Size:	75,6 KB 
ID:	231
    Click image for larger version. 

Name:	3.jpg 
Views:	16 
Size:	72,5 KB 
ID:	233
    It's in german, but should be understandable.
    The anisotropic setting and lod-bias to "allow", is for having the best possible quality textures, in combination with "TCG LOD Bias".

    Cemu settings:
    - Enable V-sync "off"
    - graphics pack: fps++, BSoD Framerate Unlocker
    - GX2setGPU fence skip (HACK) "enabled"
    - Experimental: Fullsync at GX2DrawDone() "enabled" (have this enabled make me lose ~ 10 % fps, but only option to prevent the AI/distance bug)
    - gpu buffer cache accurace "Low (fast)"
    - cpu-mode "dual-core" (more fps for me then triple-core)
    - pre-compiled shader cache "enabled (setting this to disabled/ignore, will make me lose ~ 10 % fps)
    - custom timer "qpc" ( setting this to any other, will make me lose ~ 10 % fps)
    Last edited by faW4t; 13.01.2018 at 18:56.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •