Results 1 to 5 of 5
  1. #1
    New user
    Join Date

    GX2DrawDone and low FPS in BOTW

    Is there any solution to run ZBOTW at solid 30 fps having GX2 enabled? If I disable it:

    1.- Enemies get bugged when they are far from Link.
    2.- Camera Rune can't detect objects so they can't be added to the Hyrule Compendium.

    Frame drops do not happen as soon as I play the game. Only a couple of minutes after using the Camera Rune. The rest of the game runs almost perfectly. At least at 30 fps (which is the way the devs made this game and the way I like to play it).

    I know a lot of people suggest to turn GX2 off to gain performance but constantly having to deal with those 2 issues breaks the experience.

    Also setting the GPU buffer cache accuracy from Low to Medium in Cemu 1.11.3 does not fix anything.

    My system:

    I7 4790K
    16 GB RAM DDR3
    GTX 980 Ti

    W10 x64 Pro
    Cemu 1.11.3 (using the triple-core recompiler but I've also tried with the other modes)
    Cemu hook 5.6.2

    I'm also using some graphic packs to improve the image quality and the resolution but I've tried to disable all of them and the same thing happens.

    Finally I want to make it clear: I'm not having any stutter (my shader cache is ok) but an important framerate decrease some minutes after using the Camera Rune due to the GX2DrawDone feature.

    Any solution?
    Last edited by Javsp; 08.01.2018 at 16:57.

  2. #2

    What speed are your 4790K and your RAM running at? Also keep in mind that the newest nvidia driver (the 390 one) is already known to cause problems and performance issues on cemu. Try using DDU to uninstall everything and reverting to the 388 one and see if that helps.
    What graphic packs are you using exactly? And how big is your shader cache (maximum number shown while compiling it)? Did you already try adding "accurateShaderMul = min" under the [Graphics] section in your game profile?

  3. #3
    New user
    Join Date
    Thanks for replying,

    My CPU is at default clock: 4 Ghz (4.40 in Turbo mode).
    RAM speed: 2133 Mhz.

    This issue happens with the latest Nvidia driver and with the older ones.

    I usually use the following graphic packs:
    - 1440p
    - High resolution shadows
    - Clarity
    - FPS++ (locked at 30 fps)
    - LWZX Crash Workaround
    - Enhanced Reflections
    - NVIDIA Explosion Smoke
    - Square Kakariko Torch Shadows Fix

    Now, I've tried to disable all of them and it did not fix the problem.

    My shader cache size is 9100 (more or less). Each session can add 2 or 3 new shaders to the cache.

    I'm currently not using "accurateShaderMul = min" because I've read it causes graphic glitches but I'm gonna try it right now.

    My recent findings:
    - I've monitorized the VRAM usage (using MSI Afterburner) and I've noticed when it reaches the total video memory of my GPU (6 GB) it starts to drop frames.
    - Camera rune dramatically increases the VRAM usage as well as navigating though the Hyrule Compendium.
    - Normally VRAM usage is always increasing until I close Cemu but if I do not use the Camera rune I can play this game for a long time with no issues.

    UPDATE: I've been playing for 90 min with "accurateShadermul = min" added in my game profile with no issues but VRAM usage reached almost 4GB. It would probably reached all the available VRAM after 30 minutes more of gameplay. It seems Cemu has several video memory leaks and the only real solution seems to wait for further versions.
    Last edited by Javsp; 11.01.2018 at 05:34.

  4. #4

    That seems really weird that your VRAM usage is increasing that fast while playing, I've never experienced that, even when playing for 6 hours. I would advise testing another shader cache, but I'm not allowed posting links as they contain Nintendo code. Just google "cemu shaders reddit" and on the first result you should find a reddit post with a complete shader collection. Use the one with 9.4k shaders and see if that helps.

    Also note that monitoring programs like Afterburner, etc. can cause weird problems with cemu. Try disabling them and monitor your fps via Cemu itself. Another thing to try would be, in the Debug tab, set Precompiled shader cache to "Disabled/ignored".

    Best of luck to you getting this problem solved.


  5. #5
    New user
    Join Date
    Do you have 'GX2DrawDone' enabled in Cemu?


    Do you use the camera rune and navigate though the Hyrule compendium?

    I think those 2 things are the culprit of these issue.

    Also, I'm using the BSOD Gaming's shader cache. Monitor software can cause problems with Cemu but, according to the wiki, those problems are caused by the OSD interface of these programs and I always have that feature disabled (I use a second screen to show the values).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts