Results 1 to 10 of 10
  1. #1

    Game runs 60 FPS but randomly dips to 0-1 FPS randomly.

    IntelĀ® CoreĀ™ i7-7700K CPU @ 4.20GHz
    8192 MB Single Channel (64 bit) DDR4-SDRAM 1064.4 MHz - Ratio 1:16
    NVIDIA GeForce GTX 1070 (GP104) @ 139 MHz Shader Units: 1920 / Texture Units (TMU): 120 / Render Units (ROP): 64 8192 MB GDDR5 256 bit @ 405 MHz
    SAMSUNG HD103SM 1000 GB - Note: Using RAMDISK for a separate partition of 1024MB.

    Microsoft Windows 10 (10.0) Home 64-bit

    Cemu Version: 1.11.6b
    Cemuhook Version:

    Graphic Packs:
    No Anti-Aliasing
    No Depth of Field
    NVIDIA Glitch Artifacts Workaround
    Static 60FPS Mod - Note: Using because 60 is my normal when looking around usually and sometimes fighting monsters and walking, etc, that is until it decides to drop on me.
    960x540 - Note: Tried many, have not tried the lowest one yet, however seems to become less lasting with this.

    Settings: (Will be off if checkable/default if must enabled unless I state them)

    Bilinear + Downscale
    GPU Buffer Cache Accuracy: Low
    Full Sync At GX2DrawDone()
    Console Region: USA
    Console Language: English

    Mode: Triple-Core Recompiler(fast, unstable!)
    Affinity(Hook): First Logical Core Per Physical Core(even)

    Precompiled Shader Cache(Hook): Disabled/ignored
    MM Timer Accuracy(Hook): 1ms
    Custom Timer(Hook): QPC

    Breath of the Wild Version: 208
    DLC Version: 80

    00050000101c9400 Profile Settings:
    extendedTextureReadback = true
    accurateShaderMul = min

    Cemu Compatibility Properties:
    Run This Program As An Administrator
    Disable Fullscreen Optimizations
    Override High DPI Scaling Behavior. Scaling Performed By Application

    Note: Cemu runs on another drive than where the DLC and patches exist. (Cemu on A:\ whilst mlc01 on C:\)

    NVIDIA Settings:
    Use the advanced 3d image settings:
    Cemu Program Settings:
    Anisotropic Filtering: Off
    Maximum Pre-Rendered Frames: 1
    OpenGL Rendering GPU: GeForce GTX 1070
    Power Management Mode: Prefer Maximum Performance
    Texture Filtering - Anisotropic Sample Optimization: Off
    Texture Filtering - Negative LOD Bias: Allow
    Threaded Optimization: On

    GeForce GTX 1070 Info:
    Driver: 391.35
    D3D API: 12
    D3D Feature Level: 12_1
    Video BIOS:

    I have no idea why this isn't working properly, it's fine 75% of the time but every so amount of moments it will just drop to 0 FPS, especially in combat. It'd be really useful to know what I'm doing wrong and if there are any fixes or at least some ways to reduce the spikes. It would be greatly appreciated. Also, I'm somewhat new to Cemu but I have a decent grasp on it.
    Last edited by billy61300; 24.04.2018 at 22:51. Reason: Extra Information Added.

  2. #2
    Join Date
    How big is your shader cache? Also don't use fps++ and static at the same time.

  3. #3
    It's about 9500 shaders, though upon loading it only shows 700-900. The file itself is about 75000KB

  4. #4
    Join Date
    If it only shows 700 - 900 then that is how many shaders you have and you are experiencing just in time shader compilation. Which pauses emulation until the shader(s) are ready to run.

  5. #5
    But how come it doesn't read the shaders I already have? The value doesn't change for me. So every time I get into game I experience lag. Like a bomb for example, I've used it quite a lot, but I have to throw it at least once before I can actually use it in combat.
    Last edited by billy61300; 25.04.2018 at 01:46. Reason: Example added.

  6. #6
    Join Date
    That I’m not sure on. Post your log.

  7. #7
    log.txt <--- Log.

  8. #8
    Super-Moderator epigramx's Avatar
    Join Date
    The log might be incomplete (needing to be created after fully running the game), but I see a problem in it already that could be possibly related: you downloaded the source of the graphic packs from the repo instead of the generated packs (because patches.txt has variables of fps mods in it). Get the generated packs from the 'Download Graphic Packs" button here
    Author of WiimoteHook; co-author of Static FPS mods, author of guides to game assembly patching , compiling mesa and high-res screenshots

  9. #9
    I heard of issues with the community mod packs in a video by BSoD so I was using the No DoF version from them. But I'm re-downloading the ones posted there. I'll let you know of any changes with emulation.

  10. #10
    Using the packs from the community seems to have no difference than what I was using before. (It seems locking it at 30 FPS heavily reduced the frequency of those lag spikes and has helped reduce them when it DOES happen). I also tried using the Regular Shadows GFX Pack and removed the 720p section of it, (I assumed it would go sequentially and set it to 360p and then 720p causing lag.) I'm unsure whether this has made the shadows downscale or not although it was worth it to try it. I also was tinkering around with some of the other packs and in the CEMU wiki it said not to use it unless it's better or something so I removed that, it also had stated the depth of field removal shouldn't have a performance effect unless you're on 4K (Seemingly correct as I tested it with 360p, 480p, 720p, and 1080p each with no heavy change in FPS), Only 1-3 FPS change on 60 FPS. My shaders are at almost 3k now upon loading (I set the security of the CEMU folder with my account ownership and allowed access to full control to Everyone which is what changed the shader count). So it's mainly running smoothly except for some dipping here and there (Mainly at high vertical position) for about once every 30 seconds or so lasting for 200-1500ms which isn't too bad, it's bare-able. The only thing that's kind of annoying is the error with positioning whilst moving, it appears that the character jolts up and down whilst moving (especially in flight), which is why I had the static FPS mod enabled (which is disabled). Although being that the Static FPS mod is basically a lite version of FPS++ (I think) is why it was to be disabled due to patch interference. If it's possible, is there a specific offset patch that could be added into FPS++ to fix that error or is basically just a choice between the two?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts