Results 1 to 2 of 2
  1. #1

    Unhappy Cemu 1.12.0d rejects Controller Settings after Cemu-Restart

    Operating System (OS):
    Windows 10 Pro (x64)

    CPU Model:
    AMD FX-8350 Eight-Core Processor

    GPU Model:
    GeForce GTX 970

    GPU Driver Version:

    HDD or SSD:

    RAM Size:


    Cemu Version:

    Your problem in detail:
    Iam running Cemu over Steam with Steam Link. The Controllers (Amazon Fire TV-Gamecontroller 1.Gen) are connected via Steam Link.
    Everything works fine after configuring the Controllers in Cemu by emulating "Wii U Pro Controller" with "XInput", it also shows me the connected Device and the Games are working fine with these Settings.
    But after exiting Cemu and starting it again (with same or different Game), the Controllers are not working anymore (at this moment controller0.txt still exists under controllerProfiles).
    When entering the Controller-Input Settings, all Control-Settings are gone and "disabled", even the controller0.txt is gone after closing the settings.

    What you have tried:
    I also tried emulating oder Controller Types (Gamepad etc.) without success.
    Version 1.9.0 works without issues, but haven't tried any other newer or older Version beside 1.9.0 yet.

    Additional Comments:

    Have you messed with your Virtual Memory / Page File settings?:
    Attached Files Attached Files

  2. #2

    Idea XInput issue with CEMU launched via Steam in 1.11.6 and 1.12.0

    Hi Singularetantum,

    I have experience the same issue, also running CEMU from Steam via Steam Link.

    The issue seems related to the detection/selection of the XInput devices. I will elaborate the reproduce steps once again:
    1. Start CEMU normally and configure XInput controller.
    2. Close CEMU and start it via Steam
    3. Now the Input settings previously configured are gone and the controller emulation is set to disabled. Here is a screen of how the Input Settings look:
    4. Then when I try to configure the controller e.g. select the emulated controller type, then choose the controller. Right after I select the controller from the drop-down CEMU crashes. Here is a screen in the moment CEMU crashes:

    Here is the CEMU crash log.txt.
    I have verified that the issue begin with 1.11.6 update and is available in 1.12.0. Currently, I am using 1.11.5, where everything works.

    On a side note, separate from this issue, in 1.11.6 there seems to have been an update on the number of keys to configure. The Controller keys were 24 and now there are 25. This causes issues with the controller configuration and you cannot simply upgrade and expect the controller to be configured properly, so a remap is necessary.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts