Results 1 to 4 of 4
  1. #1

    Cemu 1.12.0 + NVIDIA GFE with gamestream = Failed


    I am using Cemu 1.12.0 with Geforce Experience (on Windows 10 Version 1803) because I use the gamestream option to play from a powerfull PC to a light PC with a big 4k TV screen.

    But, it seems the last Geforce Experience update broke my setup :'( I cannot start Cemu correctly anymore and it seems there was a modification in the Gamestream service.

    For information, I use the Nvidia driver 397.93 (the last one currently).

    All my tests following :

    1. Use Cemu directly on PC1 without gamestream service (OFF)
    - Geforce Experience gamestream service is down
    - I start Cemu
    - I start a game
    = No problem

    2. Use Cemu directly on PC1 with gamestream service (ON)
    - Geforce Experience gamestream service is up
    - I start Cemu -> no problem before I start a game
    - I start a game
    = Cemu window seems to freeze and only the close button of the window is still avalaible (and I can stop Cemu without crash)

    3. Use moonlight on PC2 to access Cemu on PC1 with GFE gamestream service
    -> Same problem as the case 2

    The case 3 works perfectly before the Geforce Experience update :'(

    Notice : If I launch Cemu and start a game on PC1 before the gamestream service and then I start the gamestream service, I can start moonlight on PC2 to use the stream but my PS4 controller is not recognized in Cemu :'( But the video flux is OK on PC2.

    Is there a way to see if there is a solution on the Cemu side to keep compatibility with the gamestream option in Geforce Experience ?

    For information, my standard configuration :
    - On PC1, Cemu with NVIDIA GFE gamestream
    - Cemu exec is setup in Gamestream interface as a game which is able to be streamed
    - On PC2, I use moonlight in google chrome as an application
    - I just need to launch moonlight, chose PC1 and chose game Cemu to start a game on 4K TV with a PS4 controller (DS4Windows)

    Thanks a lot and keep up the good work.

  2. #2
    New user
    Join Date
    This is probably low priority from the cemu folks, especially since I think the culprit is the latest GFE update, but I wanted to chime in that the exact same thing has happened to me. I kind of doubt too many people stream cemu with Nvidia gamestream since there is so little found on Google about this (but I could be wrong).

    I have been using cemu over gamestream almost exclusively (both to shield tablet and shield android TV) and it has worked almost perfectly the entire time. But the latest GFE update seems to have broken it. Based on some stuff I was reading on the gamestream forums, I think it might be possible to install an older version of GFE and trick it into thinking its the most recent version. I have yet to try this out though, but I will probably try to downgrade GFE later today and see if that resolves the issue.

    Similar to OP, cemu loads up games without issue starting it directly at the console. But once you try to launch it over gamestream, cemu sort of soft crashes and becomes non-responsive. The last thing in the log before you have to kill it is the "Loading .rpx -> Map to /vol/content"

    Something OP didn't mention is that after I tried to load cemu with gamestream, I was unable to get any games to load without rebooting the system, even if directly at the console. Perhaps toggling gamestream on and off from within GFE will resolve this without a reboot, but I didn't get a chance to try it.

    GFE and Nvidia drivers are all the same as OP, and everything else was working perfectly before now. Other games still stream with gamestream, it seems to only affect cemu so far that I can tell.

    Windows 10 64bit 1803
    Cemu 1.12.0d
    AMD 2700x CPU (No OC)
    Asus x470 Mobo
    Nvidia 980ti GPU (No OC)
    32GB 3600 Mhz memory (Running at rated speeds)
    512GB Samsung 960 Pro NVMe

    EDIT:// This thread is likely the path I will take to rollback GFE and keep it from auto-updating:
    If there is interest for the few of us that use cemu over gamestream (dozens of us!), I will post updates for how this fix works.
    Just a warning, there are links to GFE not hosted on because they don't make old versions available for download, so run it through a virus checker or anything else you would normally do to stay safe.
    Last edited by drowd; 30.05.2018 at 16:24.

  3. #3
    New user
    Join Date
    Sorry for not getting back with results yesterday, but I just wanted to confirm that for the few folks that are running into this issue, its a problem with that specific version of GFE and if you backrev it just by one, gamestream with cemu works perfectly again.
    Steps are in link above, but I will repeat here:

    1) uninstall Geforce Experience from Add or Remove Programs in Windows. Reboot if desired.
    2) Download Geforce Experience from this link:
    3) Install it.
    4) It will probably autorun after installation, so just exit as best you can without agreeing to anything or logging in to your GFE account.
    5) Browse to C:\ProgramData\NVIDIA Corporation\ right click on the 'Downloader' folder, select Properties, browse to Security tab, select the Edit button, then select 'Write' in the Deny column to block all write access to this folder.
    5a) The poster on the gamestream forum did the above to the 'latest' folder instead, but I still had issues with it trying to autoupdate, and since I'm force blocking GFE updates anyways, I did the whole folder and will update manually at a later date once its fixed. YMMV
    6) Start up GFE, add your games as desired, and stream away.

    These steps should block any ninja updating and allow cemu over gamestream until Nvidia gets GFE fixed. Hope this is helpful for anyone else!

  4. #4
    To the OP and anyone else reading who uses GameStream like myself, the trick to getting Cemu working with the latest version of Geforce Experience is rather simple: disable VSync in the Cemu settings first before booting up a game in Cemu. After that, Cemu will boot up without freezing and following initial booting, you can feel also free to reenable VSync for its benefits during gameplay. Do keep in mind that if you reenable VSync, you will need to disable it next time before booting for it to not crash at boot.
    Last edited by Hifihedgehog; 03.08.2018 at 06:33.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts